Author Topic: Can dot net framework kill connection?  (Read 353 times)

StormRider

  • Newbie
  • *
  • Posts: 2
    • View Profile
Can dot net framework kill connection?
« on: May 06, 2017, 12:25:51 PM »
Our cams have been working fine for years, until recently. The only thing I can think of is that we installed dot net 4.6, but I could be wrong in remembering the timeline if the cams quit AFTER that. Plus, dot net wasn't installed on all the computers with cams.  Although, i dunno how the network affects other computers.

We have 4 cams at work and 1 cam at home. The cam at home works fine. Three of the cams at work have stopped working, and the 4th computer hasn't been rebooted for a while, and it's still running, but I bet if i reboot that one, the cam will quit too.

We've gone thru the forums and trouble shooter and tried everything we read, but they still just say "connecting..." and stay greyed out. On the mobile app, it was saying cannot connect to all cam sources, but it showed 2 of them live.

Not sure what else to try.

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2212
    • View Profile
Re: Can dot net framework kill connection?
« Reply #1 on: May 07, 2017, 01:07:14 PM »
What version of Windows are you currently running on the computers at work?

When you click the Start button on the iCamSources at work that are not working and you only see "Connecting ..." in the title bar, do you see the video preview in the iCamSource window? Or when you say they "stay greyed out" is that the video preview?

One thing you can try is to quit the iCamSource applications and clear the iCamSource registry settings in case they have gotten into a bad state. If you download and double-click the following registry file, that will clear the registry settings for you: http://skjm.com/icam/CleaniCamKey.reg

Then, if you re-launch the iCamSource and re-enter your camera info, hopefully you will see your video previews and be able to connect.

StormRider

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Can dot net framework kill connection?
« Reply #2 on: May 09, 2017, 03:57:15 PM »
Thank you. That registry thing fixed 2 out of 3 cams. The last one is on Windows 7x32.  The box stays grey on the preview screen.

He's tried uninstalling, fixing registry, plugging in different usb spots, updating cam drivers, taking the cam off the extension cord. None of that worked. I wonder what happened?  His was the main computer that installed dot net framework.

Anything else we can try ?

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2212
    • View Profile
Re: Can dot net framework kill connection?
« Reply #3 on: May 10, 2017, 10:02:06 PM »
What brand and model is the webcam?

Have you tried temporary unplugging other USB peripherals to see if that has any effect when re-launching the iCamSource and choosing the webcam? It may be that the USB is somewhat overloaded on the final computer.