Author Topic: Icam with my 4G dongle/router  (Read 486 times)

SeanJ

  • Newbie
  • *
  • Posts: 34
    • View Profile
Icam with my 4G dongle/router
« on: March 06, 2017, 04:23:37 AM »
Hi guys,i've been running icam for many years using cable broadband without any fuss,  i've recently moved to somewhere without cable  and am now using a Huawei E5577Cs 4G mobile dongle/router to connect to the 4gmobile network for all my internet access. 

I'm struggling to make icam connect remotely into my home network  - it works fine when i'm connectin at home though.

When I check the 'auto configure' box on icam source it says:

'UPnP Dual NAT ext ip: 10.25.105.XXX' , this WAN ip address changes on each reboot of the router (when I check the  auto configure box on  icam source i lose the webcam image on my iphone)

When i use any of the port checking sites the 10.25......    address isn't used (as it is in auto configure in  icam source) and my public ip address : 85.255.234.XXX   is used with the result 'ports closed' or 'not visible'.

I'm guessing my open ports aren't even seeing my public 85.255.234 XXX address as it seems icam auto configures the WAN (10.25.105.XXX)  address and not my public one if i'm understanding this right?

This router does support port forwarding as the gaming community use it and it has pretty good features configuration wise (virtual server/dmz/nat/upnp etc)  My ports from 12000-12005 are all open but they aren't accessible via my public ip it seems so i'm stuck there for the moment unless anyone can help?

Hopefully this makes sense to someone who knows a bit more than me and give me a steer, possibly mobile dongles are a non starter for this but i'm hoping not.  :)

cheers. Sean
« Last Edit: March 06, 2017, 12:40:23 PM by SeanJ »

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2212
    • View Profile
Re: Icam with my 4G dongle/router
« Reply #1 on: March 06, 2017, 01:16:11 PM »
The general problem is that 4G connections aren't really meant for server applications. You aren't assigned an external, internet-addressable IP address when you have a 4G connection, and since the iCamSource is essentially a server that iCam connects to, that is the issue.

Do you have more than one router on your network? Or are you just connecting to the Huawei device? The "Dual NAT" message indicates that there is more than one router on the network, but it may just be that the device is not being assigned an Internet-addressable IP by your mobile provider, and then it is sharing that IP from within another internal NAT network.

It sounds like you have ports forwarded, so are those ports being forwarded in your Huawei device? If your Huawei device is not assigned an Internet-addressable IP address I'm not sure what port forwarding would even accomplish, like you said.

One solution is to use proxy data, which uses either our server or another user's public iCamSource to accept connections from both your iCamSource and your iCam: http://skjm.com/icam/help/proxy.php

SeanJ

  • Newbie
  • *
  • Posts: 34
    • View Profile
Re: Icam with my 4G dongle/router
« Reply #2 on: March 06, 2017, 02:03:24 PM »
Thanks for your input Stefan, yes i am only using the Huawei E5577Cs Router/dongle - nothing else. It's a great little modern dongle with good features but I think your porobably right in that it is not a visitable server by outside requests (to the best of my limited knowledge). I guess the comparison with gamers and their use of such units isn't comparable after all. I'll explore the proxy option and see how I fare with that.  many thanks.

SeanJ

  • Newbie
  • *
  • Posts: 34
    • View Profile
Re: Icam with my 4G dongle/router
« Reply #3 on: March 10, 2017, 06:49:19 AM »
Hi again Steph, i have had success with the public/private proxy method thanks - just one question though, does this method still rely on all the same router and port settings that would have been setup for standard non-proxy use I wondered?

thanks. Sean

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2212
    • View Profile
Re: Icam with my 4G dongle/router
« Reply #4 on: March 10, 2017, 10:54:30 PM »
Glad to hear that things are working well for you!  8)

As for your question, no, using proxy data does not rely on router / port settings as it only requires that the iCamSource and iCam be able to make outgoing connections to a shared proxy server.