Author Topic: iCam Source could not be connected to  (Read 1872 times)

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2191
    • View Profile
Re: iCam Source could not be connected to
« Reply #15 on: January 12, 2017, 07:22:34 AM »
One other update ... It seems that on our test T-Mobile phone that if we turn on Airplane mode (resetting the LTE connection) and then visit the http://ipv6-test.com/ link, the "Fallback" test fails with a red "No".

Then, when launching iCam Pro, we get a Broker Connection Error.

Then, (and this is where things get strange) if we launch our iSpy Cameras or iSpy Cameras Free app (http://skjm.com/ispy/) the public IP cameras will eventually start to connect, which is not expected if there was no IPv4 connectivity.

Then, if we go back to the http://ipv6-test.com/ link, the "Fallback" test fails with a passes with a green "to IPv4 in 1 second" and iCam Pro works. :o

We are still looking into WHY this is the case, but am wondering if this same strange work-around works for you.

If we had to guess, we think it has something to do with T-Mobile's network, and how they're handling the IPv6-to-IPv4 fallback / translation.

Beyondthetech

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: iCam Source could not be connected to
« Reply #16 on: January 17, 2017, 09:52:52 PM »
I sent you my results of the iPv6 test. Is there any way to figure out then implement whatever code you're executing in iSpy prior into iCam Pro then?

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2191
    • View Profile
Re: iCam Source could not be connected to
« Reply #17 on: January 18, 2017, 07:06:36 AM »
I sent you my results of the iPv6 test. Is there any way to figure out then implement whatever code you're executing in iSpy prior into iCam Pro then?

We are currently completing and testing changes to iCam Pro to work with T-Mobile's IPv6-only network, and should be releasing an update to iCam Pro soon. :)

ckuehne

  • Newbie
  • *
  • Posts: 21
    • View Profile
Re: iCam Source could not be connected to
« Reply #18 on: January 31, 2017, 01:28:54 PM »
Just wanted to know what the latest is on this?

Thank you.

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2191
    • View Profile
Re: iCam Source could not be connected to
« Reply #19 on: January 31, 2017, 06:23:24 PM »
Just wanted to know what the latest is on this?

Thank you.

In finishing up our testing we also updated to iOS 10.2.1 and installed the T-Mobile 27.2 Carrier Update ... And it looks like the IPv6-only issue has been fixed. >:(

Have you updated to the latest version of iOS and the Carrier settings? If so, are you still seeing the issue?

ckuehne

  • Newbie
  • *
  • Posts: 21
    • View Profile
Re: iCam Source could not be connected to
« Reply #20 on: January 31, 2017, 06:32:37 PM »
While I had updated to 10.2.1 - it did not tell me there was a carrier update - I just updated it, and it works!

Thank you for the reply.

ckuehne

  • Newbie
  • *
  • Posts: 21
    • View Profile
Re: iCam Source could not be connected to
« Reply #21 on: February 01, 2017, 02:45:53 PM »
Spoke too soon. I can only connect through Wifi again.

I can't connect again through cellular - it sounds like you guys were just about to release that update, is that an any day now kind of status?  The iSpy app always connects, still.

I'm running the latest iOS and Carrier updates.

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2191
    • View Profile
Re: iCam Source could not be connected to
« Reply #22 on: February 01, 2017, 08:53:53 PM »
Spoke too soon. I can only connect through Wifi again.

I can't connect again through cellular - it sounds like you guys were just about to release that update, is that an any day now kind of status?  The iSpy app always connects, still.

I'm running the latest iOS and Carrier updates.

Yes, we're hoping to have it submitted / released by the end of the week.

ckuehne

  • Newbie
  • *
  • Posts: 21
    • View Profile
Re: iCam Source could not be connected to
« Reply #23 on: February 01, 2017, 10:10:56 PM »
That's wonderful!

Thank you.