Author Topic: Webcam Authorization Failure  (Read 1241 times)

BV

  • Newbie
  • *
  • Posts: 3
    • View Profile
Webcam Authorization Failure
« on: June 11, 2016, 10:55:17 AM »
Newbie here,

I have an Axis 5414 PTZ cam that I get a  "401 Webcam Authorization Failure when I try to activate the cam in the normal manner"  I read the thread from SEV about the Foscam problem after a firmware update and tried that solution below:

"It looks like the new firmware will support the following MJPEG URL that is compatible with the iCamSource: "h-t-t-p://IP:PORT/videostream.cgi?user=USERNAME&pwd=PASSWORD"

I can type in this URL string into my browser and iPhone and I get the camera image with no problem.  When I type in the same string into IcamSource pro "Mac OS" I still get the 401 error.

I understand the PTZ function might not work, I just want the video.

can you help

SKJM Support

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1917
    • View Profile
Re: Webcam Authorization Failure
« Reply #1 on: June 14, 2016, 12:57:27 AM »
We havenít tested with that particular camera, but if it outputs MJPEG formatted data, itíll probably work with iCamSource.

When you run iCamSource, youíll need to select the "Ethernet /Wi-Fi" tab because the camera is a network camera, not a USB camera. Then, enter the MJPEG or JPEG URL for your camera.

If the MJPEG or JPEG URL isnít something that can be found by searching around with Google or by contacting their support, we actually have another solution available, although it is currently in its very preliminary stages, and that is: http://skjm.com/icam/mjpeg_test.php

When you enter the cameraís IP address and port into that web page, it will attempt to connect to the camera using all of the common MJPEG and JPEG URLs that we are aware of. If any of the URLs produce an image, then that is the URL to use in iCamSource.

If your camera requires a login and password, you can enter them in that webpage right before the address : login:password@Camera_address

BV

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Webcam Authorization Failure
« Reply #2 on: June 14, 2016, 10:05:55 PM »
Thank you for the reply,

Using your utility, there were 4 different URL's that delivered images.  This camera requires a password, I tried all of them with username and password before the camera address "H-t-t-p://LOGIN:PASSWORD@10.0.1.15:80/mjpg/video.mjpg".  Also, tried these URL strings with the user name and password and the end of the URL string as described in my first post.  I still get a 401 error in all cases.

The camera output is MJPG format data

BV

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Webcam Authorization Failure
« Reply #3 on: June 15, 2016, 10:15:32 PM »
I found the problem

Allow password type setting in the camera needs to be changed to unencrypted.


logging into the Axis 5414 camera, go to system options, security, then to the users page. near the bottom of the page there is a listing "HTTP/RTSP password setting" and allow password type.  the pulldown gives three settings; encrypted/unencrypted---encrypted---unencrypted.   Default setting is encrypted/unencrypted and this will not work.  When changed to unencrypted, all of the URL's listed in the utility link you gave me worked.

thank you for the support

BV

SKJM Support

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1917
    • View Profile
Re: Webcam Authorization Failure
« Reply #4 on: June 18, 2016, 12:47:30 AM »
I apologize for the delayed response. Iím glad you got it working!

If you have any other issues or questions, please let us know.