Author Topic: "Cannot Connect To iCam Broker Server" on EDGE or 3G - Fix coming in iCam 1.0.2  (Read 34178 times)

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2191
    • View Profile
If you are receiving the iCam "Cannot Connect To iCam Broker Server. Please try again later." error message when trying to connect via EDGE or 3G, here is one thing you can try: Open another iPhone network application (such as Stocks or Weather) and then see if iCam works after that.

This is a strange issue that we cannot reproduce but a small number of users have reported having. If you are among them (and running Stocks or Weather fixes the issue until you restart your iPhone) please post your experiences here or contact support@skjm.com.

Thanks!  :)
« Last Edit: December 08, 2008, 04:02:17 PM by Stefan »

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2191
    • View Profile
Re: "Cannot Connect To iCam Broker Server" on EDGE or 3G
« Reply #1 on: December 07, 2008, 04:13:39 PM »
UPDATE

If, when you run iCam when it is connecting over 3G or EDGE and you repeatedly see the following message: "Connection Error - There was an error connecting to the iCam Broker Server. Please try again later." we have made progress in tracking this problem down.

When you see this error message, if you then open another iPhone network application like Stocks or Weather and are then able to connect via iCam, then this is a bug that we are aware of and are now able to reproduce.

I do have a question, however: In your iPhone settings, under Fetch New Data, do you have Push enabled? Also, what is your Fetch schedule setting (15 min, 30 min, 1 hour, or manual)? Currently when I disable Push on my iPhone and set the Fetch to Manual, I can reproduce the error message after letting my iPhone sit idle for a few minutes.

The assumption is that the iPhone most likely disengages its connection with the cellular network after a period of inactivity, and therefore when iCam starts up, it is unable to access the internet. I assume that the iPhone does not re-enable the 3G internet connection when it attempts to contact the Broker Server via UDP ... That is why running an application that uses TCP connections causes iCam to subsequently work.

We are looking into a solution to this problem that is more elegant than the current one of having you run another network application before running iCam. I anticipate it to be included in the upcoming 1.0.3 iCam release that should be available in the App Store within the next week or so.

syousuff

  • Newbie
  • *
  • Posts: 1
    • View Profile
I just bought the app today. I am getting the error message "Connection Error - There was an error connecting to the iCam Broker Server. Please try again later."  I am experiencing this over a strong WiFi connection, not Edge or 3G as previously reported. I also have Push enabled and Fetch set to every 15 minutes. Stocks and Weather both work perfectly when I tried launching these before iCam.

I have a Macbook Pro C2D 2.33 GHz, 3GB RAM running 10.5.5. My husband installed iCam source on his Macbook running 10.5.5 (to see if there was a problem with our network) and I had no problems connecting to his iSight with iCam.

I tried uninstalling/reinstalling the app as well -- no success.

Any ideas on how to fix the problem?

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2191
    • View Profile
syousuff - After checking the Broker Server logs it seems like your iPhone and MBP have the same external IP (are behind the same router) but have a different class of internal IP (10.0.1.xxx vs. 192.168.2.xxx). Is your MBP connected via both WiFi and Ethernet? Because it seems like they're on different internal networks.

Your husband's MacBook seems to be on another 10.0.1.xxx IP address, so that would be why it can connect without a problem.

Hope that helps. :)

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2191
    • View Profile
UPDATE #2

Since Apple has yet to approve our 1.0.2 for App Store release, I have re-submitted a build to include this additional bug fix, so once 1.0.2 is approved, this issue should be fixed.  8)

ChasteDylan

  • Newbie
  • *
  • Posts: 2
    • View Profile
I'm having the same issue as some people on the forum. The rainbow color issue now seems to be resolved for me on vista machines along with failure of analogue video cameras to connect at all, but.... I'm still have fundamental connection issues. Basically, I cannot seem to view streams unless my iphone and all cameras are all connected to the same wifi network. Any cameras on other wifi do give me the connection error message. Also if I connect my iPhone via a different WiFi or Edge and 3g for that mater, I get that same connection issue. I too have reinstalled the app on my phone and all PCs to no avail.

If anyone could give me any guidance I would be greatly appreciative.

Thanks,
Dylan

Jay

  • Administrator
  • Hero Member
  • *****
  • Posts: 1094
    • View Profile
I'm helping Dylan through e-mail.  If info useful for this thread comes out of it,  I'll post it to the thread.

kahdmus

  • Newbie
  • *
  • Posts: 3
    • View Profile
FYI, Peer Guardian will also block the cellular connection but allow the wifi connection. If you have Peer Guardian either disable or right click on the blocked connection for your iphone and select 'allow permanently. Hope this helps someone..had me stumped for 2 weeks!!!

GillNick

  • Newbie
  • *
  • Posts: 16
    • View Profile
We have that probl. : Cannot Connect To iCam Broker Server !!!
On wi-hi is all ok.
Is there a solutions.
We are connectec( trying to be ) on PC Windows vista; ( by ethernet )
Pitty it doesnt work.

Jay

  • Administrator
  • Hero Member
  • *****
  • Posts: 1094
    • View Profile
GillNick - The most common reason for that error is a poor wireless connection.  If you see the error consistently when you have a strong wireless signal, the network you're connected to may be blocking UDP traffic. 

Could you go to http://whatismyipaddress.com/ in your computer's web browser to get your computer's IP address, and then send an email to support@skjm.com with the IP address? That way I can attempt to look it up in the iCam Broker Server logs and hopefully troubleshoot the problem.

Please refer to this forum thread in your email.

GillNick

  • Newbie
  • *
  • Posts: 16
    • View Profile
done. sent my IP .
thx
waiting

Jay

  • Administrator
  • Hero Member
  • *****
  • Posts: 1094
    • View Profile
GillNick  - I replied to all three of your emails, but it seems you're not receiving them.  The last message I sent was:

I found your IP address in the server logs.  I was able to see your iPhone connect from Wi-Fi and from a 3G/EDGE provider named SFR.  Is SFR your service  provider for your iPhone?  The fact that I can see the SFR IP address in the server logs indicates that SFR does not block UDP and that your phone is able to connect to the Broker Server on 3G/EDGE (at least some of the time).  If SFR is your provider, then the Broker Connection Errors you see are due to a poor wireless data connection.

Do you ever see a different error message on your iPhone?  Another common error message when it won't connect from 3G/EDGE is "Source Connection Error".  Have you ever seen that error message?

GillNick

  • Newbie
  • *
  • Posts: 16
    • View Profile
Yes I am at SFR so as you say they dont block my connection.
No, never an other messege .
When you say it may be due to poor wireless data connection, what connection do you mean ? 
I am "on line" now .
Can you see my place with the login and passworg I gave to you. Mean on 3G.
I dont give up. :)
thx et pls keep on working on my case !
merci

Jay

  • Administrator
  • Hero Member
  • *****
  • Posts: 1094
    • View Profile
GillNick - Yes, I was able to view your webcam over 3G.

When I say poor wireless data connection, I mean your phone has a poor 3G/EDGE wireless signal.  That is the most common reason for the "Broker Connection Error".  The other possible reason for that error is if your service provider blocks UDP traffic, but your 3G/EDGE IP address shows up in the server logs, so your provider does not block UDP (at least not all of the time).  That leaves poor 3G/EDGE signal as the probable reason for that error.

Have you ever tried connecting to your webcam from a Wi-Fi hotspot (not your home Wi-Fi)?  If so, did it work?

GillNick

  • Newbie
  • *
  • Posts: 16
    • View Profile
I will try to connect that way ( hotspot, or cyber café ) .
  What we ( 2 iphones ) did till now was to try to connect from our willage, where I know that the 3G is poor, than also wrom an other place, small town next to us, than also in Paris on two diferent locations. We never had one single connection.
Opening one port in my router? Could it help ?
Change the provider ?