Author Topic: Troubleshooting 103 - Port Forwarding  (Read 178170 times)

SKJM Support

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1917
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #105 on: May 18, 2012, 11:19:31 AM »
Hi, there

I had this working before but had to reconfigure linksys wrt600n and now I can't get icam to work over 3g network only over wi-fi. I am confused over what to set to static ip, the computer or the router. Tried the router and still not working. I can't follow the port forward guide because the screens don't match the guide. What to I do?

Thanks

Please send me a screenshot of your router's port forwarding configuration to support@skjm.com.

Also, please go to http://whatismyipaddress.com/ from the computer running the iCamSource and send your external IP address to us so we can attempt to look it up in the Broker Server logs and hopefully troubleshoot the problem. Reference this forum post and your user name in your email.

morga87

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #106 on: May 23, 2012, 06:38:35 PM »

I have done all of these steps- support email has not been able to help me for a week. I need this to work or else I need my five bucks back. I am still receiving source connection error after going through all of the steps on port forward.com. I just want this fixed. Please advise or give me my money back.



PLEASE NOTE : If you are unsure as to whether or not Port Forwarding is the solution to your problem then please start here: http://skjm.com/forum/index.php?topic=174.0

Port forwarding isn't always the solution to every connectivity problem. Sometimes it can make things worse or simply confuse the troubleshooting process. If you are receiving the Source Connection Error when your iPhone is connected via 3G/EDGE but you ARE able to connect via WiFi, then Port Forwarding is most likely the solution for you.

To use port forwarding, you will need to both enable port forwarding in the iCamSource and setup a port forwarding range in your router.

To enable port forwarding in the iCamSource:



If you are running Windows, you will need to set an iCamSource registry key:

1. Download the following file to your computer and double-click it: http://skjm.com/icam/iCamSourcePortForwarding.reg If the file opens up in notepad for some reason, please see the Registry Note below.
2. Restart the iCamSource. You should now see a checkbox allowing you to enable Port Forwarding. Check it, and you should see the range 12000 to 12100 by default.

Registry Note - If double-clicking the .reg file doesn't work, you can do the following to add it to the registry:

- Click on Start and then Run...
- Type in regedit, and then click OK
- In regedit, click on File, and then Import
- Enter the filename or otherwise locate the ".reg" file you want to enter, and click OK



If you are running Mac OS X, you will need to add an iCamSource user defaults setting:

1. Open a Terminal windows from Applications > Utilities > Terminal
2. Copy and paste the following line of text into it and press Enter:

defaults write com.skjm.icamsource PortRangeSet -bool true

3. Restart the iCamSource. You should now see a checkbox allowing you to enable Port Forwarding.  Check it, and you should see the range 12000 to 12100 by default.



The next step is to forward that range of ports in your router to the computer running the iCamSource:

1. Go to http://portforward.com/ and find your router in the list sorted by manufacturer and model.
2. Click on your router's model, and then click on the "Click here to skip this advertisement..." link in the top-right corner.
3. The iCamSource is not among their list of supported applications, so you'll need to find and click on the "Default Guide" link near the top of the page, located above the list of applications.
4. Following the default instructions, forward UDP (not TCP) ports 12000-12100 to the computer running the iCamSource.

Once this is done, you should be able to access your iCamSource via 3G/EDGE.



IMPORTANT NOTE #1 - If your router only allows you to forward a single port at a time, change the port range from 12000-12100 to 12000-12005 in the iCamSource and add 6 port forwarding rules in your router, one for each port.

IMPORTANT NOTE #2 - If you are running iCamSource(s) on more than one computer on the same network then you will need to use (and forward) a separate port range for each computer. (We recommend using 12000-12100, 12200-12300, 12400-12500, etc.)



If things are not still not working correctly, then you can first try and confirm that your port forwarding is functioning as expected. If you visit this link ...

http://portchecker.net/udp.php?p=12000

... it will open a webpage that contains a Java Applet in it (similar to iCamWeb) that will be able to listen on port 12000 for a UDP packet to be sent from a server on the Internet to your computer. If your port forwarding is functioning correctly then you should see a message saying that the port is open. If it is not functioning correctly, it should say that it is blocked.



As always, please feel free to e-mail support@skjm.com if you have any questions or concerns.

Thanks! :)

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2212
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #107 on: May 24, 2012, 11:29:09 AM »
morga87 is receiving support via e-mail.

byzman

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #108 on: May 30, 2012, 07:38:22 PM »
I need help...downloaded app recently and it works great on wifi...but when I use 3G it is sporadic...sometimes it works sometimes it doesn't...so I tried port forwarding and I believe I did the steps correctly because i tried the port testing and it said it was open...but now I cant use it on 3G...need help?

Jay

  • Administrator
  • Hero Member
  • *****
  • Posts: 1094
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #109 on: May 31, 2012, 11:06:43 AM »
Please email screenshots of your router's port forwarding settings to support@skjm.com so we can verify whether the router is configured correctly.

abronbibly

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #110 on: September 30, 2012, 09:47:24 PM »
I was able to setup port forwarding for my iMac - I have that iCamSource setup using 12000-12100 and it's working. I tried to setup my macbook using 12200-12300 and it's coming up blocked on portchecker.net for some reason.

I can't seem to get the router to allow the port forwarding for 12200-12300 when the 12000-12100 is forwarding. How can I get both machines to work with port forwarding and show up on iCam?

12000-12100 is showing open and 12200-12300 is showing blocked and I get a iCam source error when I tried to connect to the macbook using port forwarding 12200-12300.

I just noticed that if I change my router settings to be the macbook's IP address instead of my iMac's IP address, then it shows me the macbook's iCamSource instead. So the source is working - but for some reason the router won't let me assign 2 IPs a range of ports to forward. I wasn't sure what the original post mentioned when it said to setup a full range 12000-12500 and then assign each individual IP.. Can anyone clarify a little more? Both sources are working, but I can't get them to work together at the same time using both sources.
« Last Edit: September 30, 2012, 09:56:27 PM by abronbibly »

abronbibly

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #111 on: September 30, 2012, 10:30:35 PM »
I was able to figure out the issue for the multiple computers - I had to reorder the forwarding ports by IP for some reason.

One other question.. I'm trying to add a 3rd PC (not a Mac or Macbook this time) and I downloaded the iCamSource for the PC (windows7), but where do I setup the port forwarding in that version of the software? I can't run the terminal code like in Mac to get it to show up - so how do I get the port forwarding option to show up so I can assign it the correct ports?

SKJM Support

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1917
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #112 on: October 01, 2012, 06:21:14 PM »
I was able to figure out the issue for the multiple computers - I had to reorder the forwarding ports by IP for some reason.

One other question.. I'm trying to add a 3rd PC (not a Mac or Macbook this time) and I downloaded the iCamSource for the PC (windows7), but where do I setup the port forwarding in that version of the software? I can't run the terminal code like in Mac to get it to show up - so how do I get the port forwarding option to show up so I can assign it the correct ports?

Port forwarding is done in your router's settings. What is the Brand/Model of your router?

DX10Pilot

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #113 on: October 14, 2012, 01:17:09 PM »
I've tried seaching and everything suggested. I can view my Icam on Wifi but not the internet.

Port Checker says UDP Port 12000 is blocked.

Tried making a static IP   using PF setup static, still didn't work

Linksys WRT54G router.
I entered the suggested settings in the router setup  still no joy....

It says something about setting up 6 individual ports, starting at 12000 - 12005      I have no idea how to do that.

Help?????
« Last Edit: October 14, 2012, 01:19:49 PM by DX10Pilot »

DX10Pilot

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #114 on: October 15, 2012, 03:33:07 PM »
Couldnt open the port on the Linksys router, however I found a way to bypass the router and it works now. Close enuf I guess.

SKJM Support

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1917
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #115 on: October 15, 2012, 05:12:23 PM »
If you would like to continue troubleshooting please send a screenshot of your router's port forwarding configuration to support@skjm.com so we can verify the settings.

Also, if you could go to http://whatismyipaddress.com/ from the computer running the iCamSource and send your external IP address to us so we can attempt to look it up in the Broker Server logs and hopefully troubleshoot the problem.

Please reference this forum post and your user name in your email.

mikey76

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #116 on: October 17, 2012, 11:47:03 PM »
I can't connect via 3g/edge but can via wifi
I have a westell 7550 modem/router ATT it doesn't have UpNp but I can manually port forward, there was not listing for this model on port forward dot.com either
The options it give me to start/end/lan port so do I put 12000 in start 12100 in end and ? in the LAN. I tried putting 12000 for start/end/LAN it added my custom service "icam" successfully but I can't connect still via 3g, what am I doing wrong when setting up the port forwarding range fields since I have 3 fields to fill out..
Please help me

rjgvt

  • Full Member
  • ***
  • Posts: 126
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #117 on: October 18, 2012, 04:41:48 AM »
mikey,

I have a similar modem/router at a remote location and found that it was easier to bridge the modem so that it is just a modem and not a router. Then I used a Netgear router for port forwarding.

SKJM Support

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1917
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #118 on: October 18, 2012, 12:35:19 PM »
mikey76 is receiving support via email.

mikey76

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: Troubleshooting 103 - Port Forwarding
« Reply #119 on: October 18, 2012, 12:43:06 PM »
Thanks You Support Team for acknowledging my issue
I sent an email with screen shots of my westell router/modem w/ATT last night..
and I await your email with details on how to resolve the issue.

Thank
Mike