Author Topic: Windows Beta Test - Image encoding issues - RESOLVED  (Read 4512 times)

Jay

  • Administrator
  • Hero Member
  • *****
  • Posts: 1094
    • View Profile
Windows Beta Test - Image encoding issues - RESOLVED
« on: December 14, 2008, 01:18:16 AM »
UPDATE:  There is a new release available that seems to resolve this issue.  If you are experiencing this problem, please download it at http://skjm.com/icam/iCamSetup.exe and let us know how it goes.
--------------------------------------------------------

Thank you very much to everybody that has been helping beta test the new Windows version of iCamSource. 

One issue that has shown up is that the image that is displayed on the iPhone is garbled, it looks like colorful static.  This appears to be an issue with the encoding process.

If you're seeing similar behavior, please post in this thread or email support@skjm.com.
« Last Edit: December 17, 2008, 09:12:59 PM by Stefan »

somedude2k

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Windows Beta Test - Image encoding issues on Sony Vaio
« Reply #1 on: December 14, 2008, 10:58:40 PM »
I am having this same problem on a Velocity Micro desktop PC using the Xbox Vision Camera.   All i can really see on the iphone is colorful static.

Update:  I found an old Logitech Quickcam Express and it works fine.  The Xbox Vision camera still does not though.
« Last Edit: December 14, 2008, 11:08:59 PM by somedude2k »

Jay

  • Administrator
  • Hero Member
  • *****
  • Posts: 1094
    • View Profile
Re: Windows Beta Test - Image encoding issues
« Reply #2 on: December 15, 2008, 12:04:50 PM »
We were finally able to replicate this colorful static behavior.  That will make it much easier to diagnose what's causing the problem.  Hopefully, we'll have an update out to fix it within the next couple of days.   When a fix is available, I'll post to this thread.

Thanks to everybody for your patience.

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2212
    • View Profile
Re: Windows Beta Test - Image encoding issues
« Reply #3 on: December 15, 2008, 01:42:14 PM »
Here are some screenshots of what the "rainbow static" looks like.

Stefan

  • Administrator
  • Hero Member
  • *****
  • Posts: 2212
    • View Profile
Re: Windows Beta Test - Image encoding issues
« Reply #4 on: December 15, 2008, 01:55:38 PM »
And here is what the image is supposed to look like. (It also appears that the image is flipped vertically, which is odd.)

Jay

  • Administrator
  • Hero Member
  • *****
  • Posts: 1094
    • View Profile
Re: Windows Beta Test - Image encoding issues
« Reply #5 on: December 15, 2008, 11:07:55 PM »
After a full day of debugging we believe we have fixed the issue.  If you are experiencing the rainbow colored images on your iPhone, please install this update on your Windows machine and let us know how it goes:

Edt: Removed link to version 0.1.1, added link to latest version

http://skjm.com/icam/iCamSetup.exe

« Last Edit: December 17, 2008, 04:00:40 PM by Jay »

Jay

  • Administrator
  • Hero Member
  • *****
  • Posts: 1094
    • View Profile
Re: Windows Beta Test - Image encoding issues
« Reply #6 on: December 16, 2008, 12:57:23 AM »
We added another fix in, so there's a new version to download :)

Please download it at: http://skjm.com/icam/iCamSetup.exe

I updated the post above with a link to the new version.
« Last Edit: December 17, 2008, 04:00:58 PM by Jay »