SKJM Forum

Support => iCam Support => Topic started by: Stefan on August 12, 2009, 01:39:33 PM

Title: Troubleshooting 103 - Port Forwarding
Post by: Stefan on August 12, 2009, 01:39:33 PM
PLEASE NOTE : If you are unsure as to whether or not Port Forwarding is the solution to your problem then please start here: http://skjm.com/forum/index.php?topic=174.0

Port forwarding isn't always the solution to every connectivity problem. Sometimes it can make things worse or simply confuse the troubleshooting process. If you are receiving the Source Connection Error when your iPhone is connected via 3G/EDGE but you ARE able to connect via WiFi, then Port Forwarding is most likely the solution for you.

To use port forwarding, you will need to both enable port forwarding in the iCamSource and setup a port forwarding range in your router.

To enable port forwarding in the iCamSource:



If you are running Windows, you will need to set an iCamSource registry key:

1. Download the following file to your computer and double-click it: http://skjm.com/icam/iCamSourcePortForwarding.reg If the file opens up in notepad for some reason, please see the Registry Note below.
2. Restart the iCamSource. You should now see a checkbox allowing you to enable Port Forwarding. Check it, and you should see the range 12000 to 12100 by default.

Registry Note - If double-clicking the .reg file doesn't work, you can do the following to add it to the registry:

- Click on Start and then Run...
- Type in regedit, and then click OK
- In regedit, click on File, and then Import
- Enter the filename or otherwise locate the ".reg" file you want to enter, and click OK



If you are running Mac OS X, you will need to add an iCamSource user defaults setting:

1. Open a Terminal windows from Applications > Utilities > Terminal
2. Copy and paste the following line of text into it and press Enter:

defaults write com.skjm.icamsource PortRangeSet -bool true

3. Restart the iCamSource. You should now see a checkbox allowing you to enable Port Forwarding.  Check it, and you should see the range 12000 to 12100 by default.



The next step is to forward that range of ports in your router to the computer running the iCamSource:

1. Go to http://portforward.com/ and find your router in the list sorted by manufacturer and model.
2. Click on your router's model, and then click on the "Click here to skip this advertisement..." link in the top-right corner.
3. The iCamSource is not among their list of supported applications, so you'll need to find and click on the "Default Guide" link near the top of the page, located above the list of applications.
4. Following the default instructions, forward UDP (not TCP) ports 12000-12100 to the computer running the iCamSource.

Once this is done, you should be able to access your iCamSource via 3G/EDGE.



IMPORTANT NOTE #1 - If your router only allows you to forward a single port at a time, change the port range from 12000-12100 to 12000-12005 in the iCamSource and add 6 port forwarding rules in your router, one for each port.

IMPORTANT NOTE #2 - If you are running iCamSource(s) on more than one computer on the same network then you will need to use (and forward) a separate port range for each computer. (We recommend using 12000-12100, 12200-12300, 12400-12500, etc.)



If things are not still not working correctly, then you can first try and confirm that your port forwarding is functioning as expected. If you visit this link ...

http://portchecker.net/udp.php?p=12000

... it will open a webpage that contains a Java Applet in it (similar to iCamWeb) that will be able to listen on port 12000 for a UDP packet to be sent from a server on the Internet to your computer. If your port forwarding is functioning correctly then you should see a message saying that the port is open. If it is not functioning correctly, it should say that it is blocked.



As always, please feel free to e-mail support@skjm.com (support@skjm.com?subject=iCam Port Forwarding Help) if you have any questions or concerns.

Thanks! :)
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Bill_martin1@mac.com on August 18, 2009, 03:27:18 AM
defaults write com.skjm.icamsource PortRangeSet -bool true

I installed the above line in my terminal Mac OS 10.5.8 and the source error disappeared. Reception is perfect. However my isight camera on my iMac G5 no longer works with any other program, iChat, Skype, everything but iCam. iCam works perfectly but so what if it takes out my other services. iCam is a lovely program but I will have to dump it if we can't resolve this.

1. how do I remove the above line from the terminal program?
2. and is there hope of some additional terminal line that will make everything work??
3. thank everyone that has been helpful.

bill_martin1@mac.com
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on August 18, 2009, 01:02:55 PM
That terminal line only affects the way that the iCamSource connects to iCam, it doesn't affect your camera in any way.

Are you trying to use your camera when the iCamSource is already engaging it? I am not sure how things would react if multiple applications are attempting to connect to the same camera at the same time, as they may fight over it.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Bill_martin1@mac.com on August 29, 2009, 07:54:43 AM
question::::::Are you trying to use your camera when the iCamSource is already engaging it? I am not sure how things would react if multiple applications are attempting to connect to the same camera at the same time, as they may fight over it.

I would be content is if were one or the other. After the latest line insertion in the terminal window. iCam always works perfectly and only photo booth continues to work. iChat& Skype both have no camera. I am still fiddling with the port setting but have to shut down the modem and restart before I can get the usual access. I am dealing with that in another forum.  The iChat drop-down just shows telephones no video.
I am off to do another restart on the modem.  Hopefully,  I'll come back with what works.
bill
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Bill_martin1@mac.com on September 02, 2009, 11:22:38 AM
Okay, I am back. Turns out it was ATT not me. They have changed how to access a 2wire modem. I am on a iMac G5 with Mac OS 10.5.8. 2.1 Ghz PowerPC G5 with 2.5 GB DDR2 SDRAM.  Here's where it stands at this time. I can get the iChat camera to show in it's preferences if iCam is turned off. I haven't looked at skype yet. However, the icon in the iChat drop down remains a telephone only and now the video preference box states camera is in use by another application when iCam is on. Turning iCam completely off seems to be the only way to use iChat. It's not enough to stop iCam in it's preferences It must be Quit in the iCam menu bar drop own. I have the port forwarding set to 12000-12005. iCam reception is perfect and quick however now I must turn it off every time I come home in order for it not to grab the camera from iChat. The whole point of course is to add cameras and be waked up if there is a significant movement in my yard. I have it set to least sensitive and it still goes off over what must be spiders. There is no one in the house and I am in the other room.

question::::::Are you trying to use your camera when the iCamSource is already engaging it? I am not sure how things would react if multiple applications are attempting to connect to the same camera at the same time, as they may fight over it.

I would be content is if were one or the other. After the latest line insertion in the terminal window. iCam always works perfectly and only photo booth continues to work. iChat& Skype both have no camera. I am still fiddling with the port setting but have to shut down the modem and restart before I can get the usual access. I am dealing with that in another forum.  The iChat drop-down just shows telephones no video.
I am off to do another restart on the modem.  Hopefully,  I'll come back with what works.
bill
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on September 02, 2009, 03:52:06 PM
There is likely a problem with iChat and iCam "fighting" over use of the camera, so there is probably not be a better solution for that issue.

In your yard are there any trees that blowing wind would trigger it, or is the image particularly dark or noisy?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: jmy on October 03, 2009, 04:35:26 PM
I just purchased the iphone app and installed icamsource, but I'm having the server connection problem (works fine over wifi, gives "source connection error" message over 3G).  I have a PC running XP and a WRT54GS router.  When I run the portchecker applet it says "UDP Port 12000 BLOCKED". 

I followed the directions at portforward.com: I unchecked "block anonymous internet requests" and added a port-range forward entry for ports 12000-12100 (I'm using DHCP because I'm having trouble setting up the router with a static ip, but I entered the same ip address in the forwarding entry as the one that shows up in my network connections control panel).  The port was still blocked.

I tried switching the router to DMZ mode, but it's still blocked.

I turned off the windows firewall and disabled Norton antivirus but it was still blocked.

Any suggestions?

Many Thanks in advance.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on October 03, 2009, 06:53:19 PM
What is the make and model of your modem? Some DSL modems also act as a router, further complicating the port forwarding issue.

If that is the case, you would need to forward the same ports from your DSL modem / router to your Linksys router's external IP address given to it by your DSL modem / router.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: jmy on October 03, 2009, 07:06:02 PM
The modem is a ZyXEL P-600 Series, Model No P-660R-ELNK

quick update:

in the configuration window for the modem I see a section labeled "NAT - Edit SUA/NAT Server Set" where I can enter a list of "Start Port No", "End Port No", and "IP Address".  Is that where the port forwarding can be done by the modem by any chance?

Thanks
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on October 04, 2009, 09:56:29 AM
It looks like your modem is indeed also a router, as it is listed on portforward.com:

http://portforward.com/english/routers/port_forwarding/ZyXEL/P-660R-ELNK/default.htm

Some DSL modem/routers allow you to forward all of the traffic to a single IP address (often called the DMZ), which in this case would be your other router. It will have to be the external IP address assigned to your router by the modem/router, not the IP address that you use to connect to your router from your web browser.

You could also forward the same port range, if you want, instead of all of the traffic, but I would suggest forwarding all of your traffic from the ZyXEL to your Linksys just to keep your network more manageable.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: jmy on October 04, 2009, 10:29:39 AM
Great!  That worked!  The portchecker now says port 12000 is open.  However, I'm still getting a "source connection error" when using 3G.  I tried disabling the firewall and NAV again but that doesn't help.

Any suggestions?

Thanks.

*** Update:

Now it's working perfectly!  I don't think I did anything special.  In fact I turned the firewall and NAV back on since testing it this morning, but now it works.

Awesome!!

Thank you again.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on October 04, 2009, 03:01:44 PM
Excellent news! :D
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: jmy on October 04, 2009, 05:26:14 PM
well, it was too good to last of course  :P

The ports are closed again, even though I've got port forwarding enabled on both the ZyXEL modem and the Linksys router.  I didn't change anything after it had started working earlier today.  I just started up icamsource and left it alone, and shortly after that I found I couldn't access the camera via 3G anymore.  Now I checked the ports with the portchecker applet and found that 12000 is blocked, again.

and I'm stumped, again...

Sorry :(
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on October 04, 2009, 08:23:51 PM
If you could send screenshots of your port forwarding screens in both routers to support@skjm.com as well as what http://whatismyipaddress.com reports your computer's external IP address is then we can hopefully look it up in the iCam Broker Server logs and hopefully troubleshoot the issue.

Please reference this support forum post and your support forum username in the e-mail.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: viop-ninja on December 14, 2009, 05:55:34 PM
Is there a command line option for the port forwarding?  I am invoking iCamSource as a service and running it with command line arguments.  I can connect over my local wifi connection just fine but cannot connect over 3G/EDGE.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Jay on December 14, 2009, 08:29:46 PM
Port forwarding is something that you configure once for a certain computer, and then you never change it again (hopefully).  It's not a setting that would change for different instances of iCamSource, so it doesn't really make sense to have a command line option for it. 

If iCam works on your local Wi-Fi, but not on 3G, the most common reason for the Source Connection Error is that your mobile and home networks use a complex port translation technique. The solution, as you've guessed, involves forwarding ports in your router to your computer running the iCamSource. There's more information about using port forwarding with iCamSource here:  http://skjm.com/forum/index.php?topic=402.0
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: viop-ninja on December 15, 2009, 09:30:35 AM
Jay,

Thanks for the response.  I think the source of confusion is that the article you linked indicates that after applying a registry patch that you need to go into the GUI and check a selection box for manual port forwarding in the application.  Since I run the app as a service I will never see these options.

I will simply try to forward ports 12000-12100 as indicated and see if that resolves the issue.

Thanks,

Jason
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Jay on December 15, 2009, 12:08:45 PM
Yeah, I can see how that would indicate that those options would be available on the command line.  Even though it is in the iCamSource interface, it is a global setting, so if you enable the port range once in the interface, it will stay enabled whenever you run iCamSource (until you uncheck the checkbox).
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: viop-ninja on December 15, 2009, 12:14:40 PM
Yeah, I can see how that would indicate that those options would be available on the command line.  Even though it is in the iCamSource interface, it is a global setting, so if you enable the port range once in the interface, it will stay enabled whenever you run iCamSource (until you uncheck the checkbox).

Thank you for the clarification!  The port forward did do the trick I can now view my feeds remotely.

If I can put one more idea in your ear it would be fantastic to be able to set this up to send motion alerts only during a specific schedule.  I would love to use this to monitor a camera at my wife's business and only send me alerts if motion is detected during evening hours.

Thanks again for the great product!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: DanMumford on December 16, 2009, 11:02:46 AM
How do I find out what my server IP address is?
Also my wireless router is connected to a computer downstairs, and my cam is connected to my computer upstairs, does this make any difference?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: viop-ninja on December 16, 2009, 11:10:34 AM
How do I find out what my server IP address is?
Also my wireless router is connected to a computer downstairs, and my cam is connected to my computer upstairs, does this make any difference?

Go to the computer that is running the iCamSource software (assuming it's windows).  Open up a console window (command prompt) and type ipconfig.  This will give you the IP address.  Be aware that this address can change when you reboot the PC or the router.  You can set up a reservation on the router so that this PC always has the same IP which makes port forwarding easier.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: debaser on April 28, 2010, 02:58:17 PM
There was something I wanted to keep an eye on in my loft today.  Last night I buy the app, install the software, and it appeared to be working as advertised.  Only today after I left did I find that it didn't work.  I'm unhappy...this was supposed to be something that worked out of the box.  Obviously I have no idea what these people (fire alarm installers) did in my place today.

Water under the bridge, I suppose.  But get me up and running soon, please.

I tried downloading the registry thing.  Got it, double clicked it, ran it.  Closed the iPhone software and reopened it.  The port forwarding stuff is there, but greyed out so I am stuck at step one.

I have sent you guys an e-mail.  

Title: Re: Troubleshooting 103 - Port Forwarding
Post by: kikecaceres on May 10, 2010, 07:37:04 PM
Hi friends !!
Finally I got it...
I followed the instructions, I opened the page of modems, chose mine, an did all the stuff and it worked...
What Im worried about is that Ill have to do this in every computer I want to connect to...
It was easier when it did it by itself.
Is there any possibility to fix this and make it automatically again??
Thanks.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: almansur on June 23, 2010, 01:36:01 PM
Sorry, but my English is very bad.

I set iCamSource in an operating system Mac OS X, I have enabled forwarding for iCamSource with the command "defaults write com.skjm.icamsource PortRangeSet-bool true". My Firewall is pfSense, I've enabled NAT port 12000-12100 UDP to my internal IP, I opened the firewall rules for ports 12000-12100 UDP.

It does not work. Any ideas?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Jay on June 24, 2010, 01:11:32 AM
almansur - If your router is already configured for port forwarding for iCamSource, I would like to try and confirm that your port forwarding is functioning as we expect it to. If you visit this link on the computer running iCamSource...

http://portchecker.net/udp.php?p=12000

... it will open a webpage that contains a Java Applet in it (similar to iCamWeb) that will be able to listen on port 12000 for a UDP packet to be sent from a server on the Internet to your computer. If your port forwarding is functioning correctly then you should see a message saying that the port is open. If it is not functioning correctly, it should say that it is blocked.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: kish on August 04, 2010, 08:13:38 AM
Hi there,

First of  all i'm just  a novice when it comes port forwarding.
I currently reading previous  notes from this forum but  I think I'm a little bit lost.

I currently got Iphone  3gs,  I could connect  through wifi , but not through 3g.

I've currently re-installed  icamsource beta, and selected auto config for port.
After selecting auto config, I, ve got the message  upnp successful  12000-12000

but  when i try to check the port through port checker: status not open or unreacheable.


I've check the setting of my  Sagem router, went to settings, and added service  udp 12000-12100

but i cant still  acces  icam through 3g.

Thank you so much in advance
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Jay on August 05, 2010, 12:58:39 AM
kish -  Does the portchecker say that the port is open now that you've forwarded the ports manually in your router?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: BrokenBelkin on August 05, 2010, 05:23:50 PM
 

     I NEED A ROUTER
        

    this app is awesome. my router is junk. unfortunately, i have the Belkin N Wireless Router F5D8236-4, that Jay has pointed out, has port forwarding issues. everything was fine with one pc, but when i tryed to add a second pc, everything quit working. did the port forwarding, did the bla bla, changed the bla bla, uninstalled, reinstalled, thought it was working for a bit on one pc ..... now i'm done .... i'm convinced it's the Belkin since i just found out about it on the forum.
      i'm getting a new router and i'm here to get some advice on which router to buy that
     "just works"  ... let my know what you have that "just worked"

            i love the support here!!!

                                  Thank You.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Jay on August 06, 2010, 12:41:58 AM
That particular Belkin model is the only router we've ever seen that issue with.  We've tested successfully with most of the other major router brands, such as Linksys, Apple, Netgear, and D-Link.   We've probably done the most thorough testing with Apple and Linksys routers (specifically the Apple Airport Extreme and the Linksys WRT54G).

Title: Re: Troubleshooting 103 - Port Forwarding
Post by: pr0fess0r on August 24, 2010, 04:42:44 PM
Hi
I'm using iCamSource 1.4.2.6 beta on Mac and the Auto-Config Router option works great for me, but I seem to have to stop the app and re-check Auto-Config Router every time I run the app or reboot my Mac as it doesn't seem to remember the setting between restarts. Is there a way around this?

Cheers

Lucas
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on August 24, 2010, 06:22:38 PM
If you close the iCamSource application (by clicking the iCamSource icon in the menu bar near the clock) and then restart it does it remember the setting? Or is it only when you reboot your Mac?
Title: Troubleshooting UPnP Error
Post by: ChiefBragg on October 19, 2010, 06:52:39 AM
Love your app and iCamSource!  I am running it on Mac OS laptop and all seemed ok with my first 3-4 cameras.  I added two new cameras this weekend for a total of 6.

I am now receiving an ERROR message from the two new ones (same type and brand - AirLink101 500w) trying to connect to iCamSource even when I choose "Auto Config Router"

I get a message to check the IP address (which is correct) and the following: Error:  UPnP 3 : NAT-PMP 3, -7, 61

I am using an AT&T  2Wire modem/wireless router.  Do you have a help document specific for 2Wire that I could use to tweak the router to see these other two cameras?

Any help appreciated!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on October 19, 2010, 12:29:58 PM
What is the "message to check the IP address" error? Are you using the MJPEG URL for your AirLink cameras from http://skjm.com/icam/mjpeg.php ?

Depending on which camera firmware version you are running, the MJPEG URL for that camera will be either http://xxx.xxx.xxx.xxx/cgi/mjpg/mjpeg.cgi or http://xxx.xxx.xxx.xxx/cgi/mjpg/mjpg.cgi where xxx.xxx.xxx.xxx is the IP address of the camera.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: ChiefBragg on October 27, 2010, 08:15:38 AM
What is the "message to check the IP address" error? Are you using the MJPEG URL for your AirLink cameras from http://skjm.com/icam/mjpeg.php ?

Depending on which camera firmware version you are running, the MJPEG URL for that camera will be either http://xxx.xxx.xxx.xxx/cgi/mjpg/mjpeg.cgi or http://xxx.xxx.xxx.xxx/cgi/mjpg/mjpg.cgi where xxx.xxx.xxx.xxx is the IP address of the camera.

The MJPEG URL is correct.

iCamSource appears to be working on the Mac laptop and all 6 cameras can be seen in the preview window but connecting to it over 3G is sporadic or it will only show 3 of the 6 cameras or periodically say source cannot be found and connecting to it later in the day will then work and all 6 cameras appear.

I still have the error message for each camera (near the AutoConfig button) (see message above) and even though all 6 cameras can be seen in the "preview window" of iCamSource, at the bottom of the column of cameras it shows "Num Connected:  0"

Any help appreciated.

Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on October 27, 2010, 11:11:19 AM
If you are seeing a UPnP / NAT-PMP error message then the router auto-configuration is failing. Does your router support UPnP or NAT-PMP?

If you uncheck the Auto-Config Router checkbox are you able to connect via WiFi and 3G?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: ChiefBragg on October 28, 2010, 10:51:55 AM
If you are seeing a UPnP / NAT-PMP error message then the router auto-configuration is failing. Does your router support UPnP or NAT-PMP?

If you uncheck the Auto-Config Router checkbox are you able to connect via WiFi and 3G?

It is an AT&T 2Wire modem/router for our UVerse TV and wireless computer network.  I will have to check the specs or a 2Wire doc to see if it supports UPnP or NAT-PMP then figure out how to change the settings.

Usually if I uncheck the Auto-Config Router checkbox it will not connect to any of the six (6) cameras for viewing in the preview window of iCamSource.  iCamSource shows a messge saying to check the IP address, cameras not found.

Today when I launch iCam on the iPhone, I can only see two of the six cameras.  Sometimes when I try an hour or so later I may see 3 or even 5... I never know till I launch the app.

Accessing via iCamWeb gives the UPnP error also.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on October 28, 2010, 05:07:58 PM
The UPnP / NAT-PMP issue shouldn't affect how the iCamSource is able to connect to network IP cameras on your network, unless the cameras need to be unplugged and re-plugged in.

(I am currently connecting to 5 network IP cameras from my Mac mini at home.)

Are you running the latest version of the iCamSource from our website?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: ChiefBragg on October 28, 2010, 06:26:51 PM
The UPnP / NAT-PMP issue shouldn't affect how the iCamSource is able to connect to network IP cameras on your network, unless the cameras need to be unplugged and re-plugged in.

(I am currently connecting to 5 network IP cameras from my Mac mini at home.)

Are you running the latest version of the iCamSource from our website?

Yes.  2.1.3    Mac OS is version 10.5.8  the last available version for my aged G4 laptop.  Also my cameras are wireless.  3 AirLink101-500W and 3 AirLink101-777W.   They all show up in the preview window most of the time in iCamSource on the Mac but connecting via iCam on the iPhone is just a roll of the dice... sometimes 2 show up, sometimes 3 or 4, once in a while all 6.  I have disabled the screen savers, sleep mode and anything that I thought might cause it to stop sending via iCamSource to the iPhone.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on October 28, 2010, 09:48:21 PM
Ah, you have an old G4? It may be a CPU issue with the iCamSource connecting to all of those cameras, then.

What is the % CPU usage for the iCamSource in the activity monitor? Also, what is the frame rate that you have set for your cameras? I currently connect to 5 network IP cameras from an Intel Mac mini and it uses about 60% of the CPU with each of the cameras sending video at 2 fps. (Increase the frame rate and you will also increase the CPU usage.) You can also try disabling motion detection for each camera to see how much that helps your CPU usage, as well as decreasing the frequency with which the motion detection logic is performed.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: dkb52 on November 01, 2010, 01:38:17 PM
It looks like your modem is indeed also a router, as it is listed on portforward.com:

Thanks for pointing that out!  Kept pulling my hair, trying to figure out the port-forwarding problem I had.  But that tid-bit fixed me up!

Using VisionNet M404 Single Port Ethernet Modem.  Under the Advanced>NAT>DMZ setting, I was able to add the IP from iCam Source (configure router).  Now everything appears to work great on Wi-Fi, AT&T Edge & 3G.

Thanks! ;D
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on November 01, 2010, 03:05:48 PM
Excellent news! :)
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: ChiefBragg on November 05, 2010, 08:13:52 AM
Ah, you have an old G4? It may be a CPU issue with the iCamSource connecting to all of those cameras, then.

What is the % CPU usage for the iCamSource in the activity monitor? Also, what is the frame rate that you have set for your cameras? I currently connect to 5 network IP cameras from an Intel Mac mini and it uses about 60% of the CPU with each of the cameras sending video at 2 fps. (Increase the frame rate and you will also increase the CPU usage.) You can also try disabling motion detection for each camera to see how much that helps your CPU usage, as well as decreasing the frequency with which the motion detection logic is performed.

Thanks for the assistance Stefan.... it was very helpful.  I originally had the settings maxed out for motion, frequency, frame rate and the default of 500 mb per camera storage.  I have tweaked things down a bit and now have all 6 cameras stable and accessible via iPhone iCam for over a week with no freezes, lockups or shutdowns. CPU usage with my new settings goes between 48%-54% (nothing else running on the Mac except basic system apps)  I may be able to tweak it UP a bit to a CPU usage of 70% but I will do that over time or leave the settings alone and add 2-3 more cameras to the system... that might get it up close to 70%!
Thanks again!!
 
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on November 05, 2010, 12:34:29 PM
You are most welcome! :)
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: dr_cambok on November 23, 2010, 06:01:54 AM
HI from Spain Stefan.
I have done everything you have posted with the ports...(forwarded them for my IP), but even with that i cant connect with my cam by 3G (no problem with wifi)
Can you help me?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on November 23, 2010, 10:56:14 AM
Does the port checker link report port 12000 as OPEN or BLOCKED? - http://portchecker.net/udp.php?p=12000
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Bud on December 04, 2010, 02:03:34 PM
Thanks Stefan
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: sharp on January 11, 2011, 02:20:32 PM
Hi there, but how about wireless modems from three broadbrand?????

Thxs
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on January 11, 2011, 04:14:55 PM
sharp is currently receiving support via e-mail.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: stevo on February 23, 2011, 10:44:25 AM
Stefan,

I'm trying to get this working behind my Cisco ASA 5510.  I've NAT'd the workstation running the iCAM source to a public IP address and opened ports 12000-12100 to the workstation.  My camera is feeding the source properly and can see the video on the workstation.  PORTchecker.net reports that 12000 is open.  I have no errors (except when I try the Router auto-config, get uPNP errors), but can't get the video feed to my Android or iPhone. I've verified that my login is correct on source and iCam.  What gives?  Any help is appreciated.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on February 23, 2011, 02:41:51 PM
What error message are you seeing when you are unable to connect: No Sources Found, Broker Connection Error, or Source Connection Error? Are you having problems connecting when your phone is connected via 3G, local WiFi, or both?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: stevo on February 24, 2011, 02:19:36 PM
Stefan,

Correction...it shows up properly on the iPhone, but my Android app doesn't display video, says only "Connecting to CamSources".  Verified that username/pw are correct. hmmm
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on February 24, 2011, 04:06:24 PM
Is this when the Android phone is connecting via 3G, the same local WiFi network as the computer running the iCamSource, or both?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: miikalep on April 21, 2011, 01:43:46 AM
Hi!

Ive read this thread and done the port forward thing, ports from 12000 to 12100 are open (portchecker confirms). iCamWeb works fine from the same wifi, not from another ip (tried mobile tethering with another computer).

With my Android (2.3.3 on a ZTE Blade) I sometimes get a connection when on the same wifi BUT it takes 15 seconds to connect and the picture refreshes only every 15 seconds. This works maybe once out of three, sometimes it only gives me an initial picture but not a feed. Trough 3G I get the usual "Source connection error" (same with iCamWeb with mobile tethering).

Strange thing is that iCamSource shows "Num connected: 1" pretty quick, in less than 5 seconds. Still no feed!? This happens trough bolth 3G and wifi.

My computer is Macbook late 2008 aluminium, running 10.5.8, iSight camera. Wifi connection is trough Zyxel P-600 modem, ADSL 10/1 Mbit/s. 3G connection is also 10 Mbit/s, reception is good. My skill level is pretty good.. Can this be just a problem with Android? My ROM is Cyanogen Mod version of Gingerbread. I have AdFreeAndroid installed, but I also tried uninstalling it and rebooting android, no difference.

Also tried with the tick box android checked and unchecked, with and without audio, different quality settings, different usernames and passwords, clearing iCam data from the phone and also reinstalling.. everything! My firewall is disabled bolth from OSX and from the router.

The performance I see in the Youtube advertisement is stunning (trough wifi probably), how come I only get one frame / 15 seconds and nothing over 3G? Is the android app not the same quality as the iOS?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on April 21, 2011, 10:13:57 PM
Is the framerate slow in the iCamSource preview window or just on the Android device?

Have you tried checking the Auto-Config Router checkbox in the iCamSource before clicking the Start button? If that doesn't work, please let me know what status message appears next to the Auto-Config Router checkbox when you run iCamSource with that option enabled.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: miikalep on April 22, 2011, 12:21:21 PM
Thanks You for a reply. The preview window is like photobooth, only a tiny lag and good framerate. Auto config works if I enable UPnP from the router, no difference in any of this. Auto config status message is "UPnP Success 12000 -> 12000".

I think the problem is not in the router, since I see the "Num connected: 1" every time and quickly. Also, after several boots of all the machines involved I've managed to get a slow videofeed trough 3G! So in some way the connection works. But only twice so far.. and with a 60 second connection time, 15 second lag and framerate of 1 / 15 s. Same thing with wifi.

So this is no longer a port forward issue, but lag and quality issue.

Is there a way to make the iSight image quality lower, other than the framerate - IQ slider? Can my phone have too little power to decode the video? Ive streamed a lot of other video with the phone and games work fine. The phone is a bit overclocked. Data speeds with the phone have been good.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on April 23, 2011, 12:28:22 PM
Is the iSight the only camera you are using? If not, what are the Brand/Models of the other cameras?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: miikalep on April 25, 2011, 04:16:48 AM
Yes, the built in iSight is the only one.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on April 25, 2011, 10:29:15 PM
What framerate do you see if you connect using iCamWeb (http://skjm.com/icam/web/ (http://skjm.com/icam/web/))?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: miikalep on April 26, 2011, 12:38:17 PM
Thank You for answering again! With iCamWeb and the same computer (as the iCamSource) I get maybe one frame a second. With android on the same wifi I get one frame in 7 seconds, on 3G one frame in 10 seconds. All with the slider next to "best frame rate". With android the image quality is really bad, with iCamWeb IQ is usable. The reliability of connection is 2/3 now. I try this several times a day.. trying to see what the dog does while alone.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on April 26, 2011, 04:25:02 PM
There are some tests we'd like to try, please send an email to support@skjm.com (http://support@skjm.com).
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: dkb52 on May 15, 2011, 09:09:49 AM
I recently started receiving iCam Source errors again.  Totally frustrating, because I was receiving "push" notices on my iPhone that motion was detected.  I started receiving the errors on Edge/3G; but all was fine on the home wi-fi network.

I remembered having the problem months ago; and went back to check which ports were being forwarded in my router settings.  Sure enough, after a system reset, my port assignments had changed, so sure enough my router was doing what it was supposed (told) to do; just the wrong ports were being forwarded (after reassignment).

Thank goodness my router has a "wizard" to tell me the ports assigned to each device.  Once I changed my forwarded ports to the correct ones, my icam & icamsource started talking together just fine on Edge/3G/home wi-fi.

Great Forum, because I can "refind" what I had to do last time to get things working!  :)
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on May 15, 2011, 11:02:35 PM
I'm glad you got it working!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: bdellisola on August 14, 2011, 10:00:14 PM
Hi, i have searched but can't find the answer to my problem.  I have multiple macs running icamsource that i must portforward to.  The problem is that i read earlier in this post that i should use a range for each, but i can't find a way to set that range for each mac/icamsource instance.

I did see in a review of an earlier version that there was a setting that allowed me to do it in preferences, but it's no longer there for me.  UPnP hasn't worked and only one of my cameras is viewable from the outside (the one assigned to 12000-12100).

I am using a DD-WRT router.  Thanks in advance!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on August 16, 2011, 01:17:37 AM
What version of iCamSource are you running? Please make sure you are running the latest version (2.3.1 BETA): http://skjm.com/icam/support.php

To enable port forwarding please see this forum post: http://skjm.com/forum/index.php?topic=402.0

If you have any problems with the instructions on that page, please send the Brand/Model of your router to support@skjm.com and reference this post so we can find port forwarding instructions for your particular router.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on August 16, 2011, 11:51:39 AM
If you are running Mac OS X, you will need to add an iCamSource user defaults setting:

1. Open a Terminal windows from Applications > Utilities > Terminal
2. Copy and paste the following line of text into it and press Enter:

defaults write com.skjm.icamsource PortRangeSet -bool true

3. Restart the iCamSource. You should now see a checkbox allowing you to enable Port Forwarding.  Check it, and you should see the range 12000 to 12100 by default.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: bdellisola on August 19, 2011, 04:13:36 PM
That worked!  Many thanks!!!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on August 19, 2011, 09:44:00 PM
I'm glad you got it working!

If you have any other issues or questions, please let us know.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: datoni on August 25, 2011, 02:15:46 PM
Dear SKJM,

Love your app! :)
Have one question. I've got things working thru wi-fi. The connection with 3G is still not working correctly. It works when the programm (icamSource) is running on my pc but when i close it my app says "no sources found"?
When using Port Checker is says it is stil blocked....(port 12000).

Any suggestions?
Thanks in advance!
Datoni from NL
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on August 25, 2011, 05:37:50 PM
Thank you for your post and I am sorry that you are having problems.

When you say "when I close it" do you mean when you close the iCam App on your phone or the iCamSource on your computer? iCamSource needs to remain running on your computer in order to view the webcam on your iPhone.

Are you receiving another error via 3G when you do have iCamSource running on your computer?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: datoni on August 26, 2011, 12:11:09 AM
thanks for the fast support!
I thought I could run this app whitout turning on my pc! Stuppid I quess??
I run a router/modem from Zyxel P-260 1HN -F1 with a Wireless Internet Camera (Sitecom wireless internet security camera 150N).

Funny thing is that i can see THE camera on THE webpage of THE camera on my iPhone whitout turning on my pc, with wifi.

 So there is no way of redirecting THE images from the camera to an iPhone with a wireless router/modem? Without Leaving THE pc on??

Thanks!
datoni
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on August 27, 2011, 11:48:58 PM
No, the iCamSource program needs to be running on your computer in order for iCam on your phone to connect to it. This is due to the firewall/NAT piercing techniques used by iCam. Also, the motion detection features of iCam (push notifications and motion recording) require iCamSource to be running in order to perform the motion detection processing.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: datoni on August 28, 2011, 02:53:46 AM
Thanks!
Great support at SKJM :)
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on August 28, 2011, 11:45:31 AM
Thank you for the positive feed back  ;D

Please let us know if you have any further questions or concerns.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Skeeter on September 06, 2011, 06:10:32 PM
I am using your trouble shooting tip post you provided to fix the source not found problem when you switch to 3G, and I get all the way to the point where you configure your router, but it does not look like the example given on the port forwarding site, I actually had to go into advanced settings and it said "     
   
Configuration File

    Use the Router's Configuration File feature to save and load configuration files, which are used to backup and restore the Router's current configuration.

     
1. To take Back up of the Router's current configuration, click the "Save Configuration File" button.
 
 
2.To Load a previously backed up configuration file, click the "Load Configuration File" button.
Note: Loading a previously backed up configuration file will overwrite the current configuration of the router.

Not sure which one to do, I do not want to mess up my router!  Thanks for the help.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on September 07, 2011, 04:38:56 PM
What is the Brand/Model of your router?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Skeeter on September 08, 2011, 10:41:14 AM
It's a Verizon/Fairpoint Westell 327W DSL Modem

Thanks

What is the Brand/Model of your router?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on September 09, 2011, 12:08:08 AM
Here is a link to the port forwarding instructions for your particular router: http://portforward.com/english/routers/port_forwarding/Westell/A90-327W15-06/default.htm
 (http://portforward.com/english/routers/port_forwarding/Westell/A90-327W15-06/default.htm)

Following these instructions:

Forward the port range 12000-12100 (UDP protocol)  to the computer running the iCamSource.

Once this is done and you've enabled port forwarding in the iCamSource program, you should be able to access your iCamSource.

To enable port forwarding in the iCamSource program, follow the directions in this forum post: http://skjm.com/forum/index.php?topic=402 (http://skjm.com/forum/index.php?topic=402)

Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Skeeter on September 10, 2011, 12:44:36 PM
I have already followed this instructions, but the screen shot examples that are given do not match what I have.  For instance, take a look at the screen capture below.


(http://skjm.com/Users/ktaylorjr/Desktop/Screen Shot 2011-09-10 at 2.37.35 PM.png)



Here is a link to the port forwarding instructions for your particular router: http://portforward.com/english/routers/port_forwarding/Westell/A90-327W15-06/default.htm
 (http://portforward.com/english/routers/port_forwarding/Westell/A90-327W15-06/default.htm)

Following these instructions:

Forward the port range 12000-12100 (UDP protocol)  to the computer running the iCamSource.

Once this is done and you've enabled port forwarding in the iCamSource program, you should be able to access your iCamSource.

To enable port forwarding in the iCamSource program, follow the directions in this forum post: http://skjm.com/forum/index.php?topic=402 (http://skjm.com/forum/index.php?topic=402)


Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on September 13, 2011, 12:31:26 AM
Skeeter is receiving support through email.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: nitramgerg on September 19, 2011, 10:29:04 AM
Hello, I recently purchased the icam app for android and have it running on my samsung galaxy s2 however when i try to add a second camera from the same network it keeps telling me that the 12000 port is blocked the only way i can get the second camera to work is alone by it self and then it will tell me the the 12000 port is blocked on the other computer my ip address is static on both pcs 192.168.1.50 and 192.168.1.51

I have to goto the router settings and open the port range from 12000-12100 with the ip address of 192.168.1.50 and the first pc's camera will work but not the second one
so I change the port settings  to                                            12000-12100 with the ip address of 192.168.1.51 and the second pc's camera will work and then it says the 12000 port is blocked on the other pc again

 if i try to open the ports on both ip addresses it says that it already exists


my router is a tp-link wr340g  and as far as i can tell i have done everything properly but just cannot seem to add the second camera at the same time
I can do one or the other just not 2 at once???
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on September 20, 2011, 10:35:36 AM
nitramgerg is receiving support through email.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: medway on September 23, 2011, 08:54:25 AM
According to your toubleshooting page I now need to do port forwarding, why is this when I didnt need to before? Also it seems that I need a static IP address which I do not want to have!

What is the solution as it seems strange that it worked fine before!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on September 23, 2011, 08:51:14 PM
According to your toubleshooting page I now need to do port forwarding, why is this when I didnt need to before? Also it seems that I need a static IP address which I do not want to have!

What is the solution as it seems strange that it worked fine before!

medway is receiving support on this forum thread http://skjm.com/forum/index.php?topic=403.new;topicseen#new (http://skjm.com/forum/index.php?topic=403.new;topicseen#new)
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: medway on September 26, 2011, 06:47:05 AM
According to your toubleshooting page I now need to do port forwarding, why is this when I didnt need to before? Also it seems that I need a static IP address which I do not want to have!

What is the solution as it seems strange that it worked fine before!

medway is receiving support on this forum thread http://skjm.com/forum/index.php?topic=403.new;topicseen#new (http://skjm.com/forum/index.php?topic=403.new;topicseen#new)

I havent received any support yet! I am still waiting!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on September 26, 2011, 10:30:52 AM
According to your toubleshooting page I now need to do port forwarding, why is this when I didn't need to before? Also it seems that I need a static IP address which I do not want to have!

What is the solution as it seems strange that it worked fine before!

medway is receiving support on this forum thread http://skjm.com/forum/index.php?topic=403.new;topicseen#new (http://skjm.com/forum/index.php?topic=403.new;topicseen#new)

I havent received any support yet! I am still waiting!

Please see the above mentioned thread.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: stickybloke on October 23, 2011, 09:31:12 AM
I think you may have answered this query earlier to another user via email...

I am getting source errors trying to use iCamsource over a "Three" Huawei E586 MiFi 3G Modem.  I am unable to find any port forwarding setting and UDP is enabled.  There are settings for "Special Applications" however:

(http://i61.photobucket.com/albums/h64/judgesaw/icam.jpg)

Is this where I need to enter the 12000-12100 bits?  What goes in the other fields?

I'm assuming this will cure my inability to connect or do you know of specific Huawei E586 settings?

Thanks
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on October 24, 2011, 10:15:44 PM
Have you tried checking the Auto-Config Router checkbox in the iCamSource before clicking the Start button? If that doesn't work, please let me know what status message appears next to the Auto-Config Router checkbox when you run iCamSource with that option enabled.

Also, the port forwarding settings may be under "Virtual Server" in the screenshot you have posted.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: z4ever on November 08, 2011, 12:24:14 PM
Good morning,
 
I just bought your application for my Iphone 3G S and work great with WiFi but with the 3G mode I have some problems
 
I have a PC in my house with a router Zyxel P 660 wifi and 2 Axis camera ip wifi, everything work good when I do the first connection with my Iphone and 3G mode, I can see all the 3 cameras working perfect and I can zoom on them too...until I close or I refresh the application on the Iphone is ok, the problem is when I try to exit from the ICam or if I try to refresh the cameras on the Iphone, then I lose completely the connection to the server and the only solution at the problem is to go on the PC and to Stop and to Restart again on the main MENU (I have to press the button down on the right of the Menu panel), then everything restart perfect
 
I tried many times and I am sure that the port forwarding is ok because my UDP 12000 port is open checking on the link that you gave, I abled the Unpg and I tried even to switch off my Norton Firewall but doesn't change anything, look's like that there is a bug on the program on the iphone if you close the application or if you try to reload the cameras because exactly in that moment you are not able anymore to connect with the server from the Iphone
 
can you help me please?
 
thank's a lot

Stefano
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on November 09, 2011, 12:15:46 AM
z4ever is receiving support via email.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Paper Giraffe on November 29, 2011, 05:36:42 PM
I was wondering if you could give me your advice. I worked with email support and had no luck as my modem needed to be bridged and I could not get it bridged.

I now have my modem bridged, external router port forwarded and when I check port 1200 it shows open. I get the "source connection error" upon opening Icam on my iphone via 3g but it does connect via home wifi.

Computer = 27" Imac IOS 10.6.8
Modem = Westell G90-610015-20
Router = Belkin f5d8233-4v3
ISP = Verison DSL Southern California
Iphone = Att Iphone 4s and Iphone 4 (tried both)
Iphone IP starts with 166
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: fabriceb on November 29, 2011, 11:29:27 PM
Help please, I have a DLink DIR632 router with 3 Foscam IP cams, set-up all as per your useful instructions and forum but i am stuck with 'UPnP Sucess 12002 - 12002'. I have disabled SPI and made sure that UDP and TCP have 'EndPoint Independent' selected.

I also have set the 12000-12100 on the computer's ip in the port forwarding rules. Running out of idea... feel like im so close of getting there, been battling with it for weeks now.

any suggestions!!!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on November 30, 2011, 12:03:06 AM
If you already have port forwarding configured on your router, I would like to try and confirm that your port forwarding is functioning as we expect it to. If you visit this link in your computer's web browser: http://portchecker.net/udp.php?p=12001 (http://portchecker.net/udp.php?p=12001)

... it will open a webpage that contains a Java Applet in it (similar to iCamWeb) that will be able to listen on port 12000 for a UDP packet to be sent from a server on the Internet to your computer.

If your port forwarding is functioning correctly then you should see a message saying that the port is "open." If it is not functioning correctly, it should say that it is blocked.

Also, please send me a screenshot of your router's port forwarding configuration to support@skjm.com (http://support@skjm.com) so we can verify the settings.

Please reference this forum post and your user name in your email.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: fabriceb on November 30, 2011, 03:48:29 PM
i confirm the port is functioning as expected and is marked as "open" from the port checker website.

I have sent you a screen shot of the port forwarding rules of the router as requested. Appreciate the prompt response
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on November 30, 2011, 10:38:21 PM
fabriceb is receiving support via email.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Weeblewobbles on December 01, 2011, 07:24:04 PM
I think you may have answered this query earlier to another user via email...

I am getting source errors trying to use iCamsource over a "Three" Huawei E586 MiFi 3G Modem.  I am unable to find any port forwarding setting and UDP is enabled.  There are settings for "Special Applications" however:

(http://i61.photobucket.com/albums/h64/judgesaw/icam.jpg)

Is this where I need to enter the 12000-12100 bits?  What goes in the other fields?

I'm assuming this will cure my inability to connect or do you know of specific Huawei E586 settings?

Thanks

Hi,

I  have the same problem with mifi and huawei e586 mobile router.  UPnP is enabled, icamsource says "connected to server", auto config is ticked, and port-forwarding on software ticked.  Not sure what I now need to do on mobilem router.  icam software on iphone (on same wifi network) gives error "one or more of the icam sources returned by the icam broker service could not be connected to".
Any & all help appreciated
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on December 02, 2011, 11:27:47 AM
Only one option should be enabled. For now, please uncheck port forwarding and let me know what status message appears next to the Auto-Config Router checkbox when you run iCamSource with that option enabled.

Also, if you're seeing the Source Connection Error when your phone and computer are connected to the same network, that indicates the problem is caused by firewall software on the computer, since the network traffic isn't going through the router in that case. Please quit or disable all firewall software on the computer running iCamSource (temporarily) to see if iCam starts working.  If it does, we can configure the firewall to work with iCam.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Weeblewobbles on December 03, 2011, 12:11:03 PM
Hi,

Only auto-config ticked now and when I start iCam source the error 'UPnP may not be enabled' appears beside the tick box.
But it has been enabled on the E586 mobile router already.  I tried disabling and re-enabling, turning off the firewall.... no joy.
When I try to connect on my iphone I still get the error 'one or more of the iCamSources...could not be connected to'.
Sorry- but I'm not the most technical of people so have no idea where to go from here.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on December 05, 2011, 10:46:57 PM
Since the Auto-Config Router option did not work you will need to forward ports to your router. You previous posted your device's settings. The port forwarding settings would be on the Security -> Virtual Server page. If you have trouble figuring out those settings, please email a screenshot of the settings on that page to support@skjm.com (http://support@skjm.com) and reference this post and your username.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Weeblewobbles on December 07, 2011, 02:26:05 PM
Hi,
I entered each of the ports ,12000 to 12005, under virtual server- an entry for each.
Then I changed the port settings in icamsource to the same. And hey presto it worked.
Many thanks for your help. A great product too!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on December 07, 2011, 08:08:32 PM
I'm glad you got it working!

Please let us know if you have any further questions or concerns.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: marcin97 on January 17, 2012, 04:04:33 PM
How do I revert registry entry on my Win7 pc? I have used the link posted in the first page of this forum to open up the ports.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on January 17, 2012, 08:34:28 PM
How do I revert registry entry on my Win7 pc? I have used the link posted in the first page of this forum to open up the ports.

The registry entry displays the Port Range checkbox in the iCamSource window, so there's no need to 'undo' it.  If the Port Range checkbox is unchecked, then it will behave exactly the same as if there was no registry entry.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: digeratimvp on February 10, 2012, 08:30:32 AM
Thanks for this tip. I needed to do this for it to work on ATT 3g and it does now indeed work. I have two computers setup and I set up 12000-12100 UDP to one computer and 12200-12300 to the other computer.
Thanks!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on February 10, 2012, 10:48:46 AM
You're most welcome.

I'm glad you got it working!

If you have any other issues or questions, please let us know.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: canoad56 on May 17, 2012, 04:51:35 PM
Hi, there

I had this working before but had to reconfigure linksys wrt600n and now I can't get icam to work over 3g network only over wi-fi. I am confused over what to set to static ip, the computer or the router. Tried the router and still not working. I can't follow the port forward guide because the screens don't match the guide. What to I do?

Thanks
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on May 18, 2012, 11:19:31 AM
Hi, there

I had this working before but had to reconfigure linksys wrt600n and now I can't get icam to work over 3g network only over wi-fi. I am confused over what to set to static ip, the computer or the router. Tried the router and still not working. I can't follow the port forward guide because the screens don't match the guide. What to I do?

Thanks

Please send me a screenshot of your router's port forwarding configuration to support@skjm.com (http://support@skjm.com).

Also, please go to http://whatismyipaddress.com/ (http://whatismyipaddress.com/) from the computer running the iCamSource and send your external IP address to us so we can attempt to look it up in the Broker Server logs and hopefully troubleshoot the problem. Reference this forum post and your user name in your email.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: morga87 on May 23, 2012, 06:38:35 PM

I have done all of these steps- support email has not been able to help me for a week. I need this to work or else I need my five bucks back. I am still receiving source connection error after going through all of the steps on port forward.com. I just want this fixed. Please advise or give me my money back.



PLEASE NOTE : If you are unsure as to whether or not Port Forwarding is the solution to your problem then please start here: http://skjm.com/forum/index.php?topic=174.0

Port forwarding isn't always the solution to every connectivity problem. Sometimes it can make things worse or simply confuse the troubleshooting process. If you are receiving the Source Connection Error when your iPhone is connected via 3G/EDGE but you ARE able to connect via WiFi, then Port Forwarding is most likely the solution for you.

To use port forwarding, you will need to both enable port forwarding in the iCamSource and setup a port forwarding range in your router.

To enable port forwarding in the iCamSource:



If you are running Windows, you will need to set an iCamSource registry key:

1. Download the following file to your computer and double-click it: http://skjm.com/icam/iCamSourcePortForwarding.reg If the file opens up in notepad for some reason, please see the Registry Note below.
2. Restart the iCamSource. You should now see a checkbox allowing you to enable Port Forwarding. Check it, and you should see the range 12000 to 12100 by default.

Registry Note - If double-clicking the .reg file doesn't work, you can do the following to add it to the registry:

- Click on Start and then Run...
- Type in regedit, and then click OK
- In regedit, click on File, and then Import
- Enter the filename or otherwise locate the ".reg" file you want to enter, and click OK



If you are running Mac OS X, you will need to add an iCamSource user defaults setting:

1. Open a Terminal windows from Applications > Utilities > Terminal
2. Copy and paste the following line of text into it and press Enter:

defaults write com.skjm.icamsource PortRangeSet -bool true

3. Restart the iCamSource. You should now see a checkbox allowing you to enable Port Forwarding.  Check it, and you should see the range 12000 to 12100 by default.



The next step is to forward that range of ports in your router to the computer running the iCamSource:

1. Go to http://portforward.com/ and find your router in the list sorted by manufacturer and model.
2. Click on your router's model, and then click on the "Click here to skip this advertisement..." link in the top-right corner.
3. The iCamSource is not among their list of supported applications, so you'll need to find and click on the "Default Guide" link near the top of the page, located above the list of applications.
4. Following the default instructions, forward UDP (not TCP) ports 12000-12100 to the computer running the iCamSource.

Once this is done, you should be able to access your iCamSource via 3G/EDGE.



IMPORTANT NOTE #1 - If your router only allows you to forward a single port at a time, change the port range from 12000-12100 to 12000-12005 in the iCamSource and add 6 port forwarding rules in your router, one for each port.

IMPORTANT NOTE #2 - If you are running iCamSource(s) on more than one computer on the same network then you will need to use (and forward) a separate port range for each computer. (We recommend using 12000-12100, 12200-12300, 12400-12500, etc.)



If things are not still not working correctly, then you can first try and confirm that your port forwarding is functioning as expected. If you visit this link ...

http://portchecker.net/udp.php?p=12000

... it will open a webpage that contains a Java Applet in it (similar to iCamWeb) that will be able to listen on port 12000 for a UDP packet to be sent from a server on the Internet to your computer. If your port forwarding is functioning correctly then you should see a message saying that the port is open. If it is not functioning correctly, it should say that it is blocked.



As always, please feel free to e-mail support@skjm.com (support@skjm.com?subject=iCam Port Forwarding Help) if you have any questions or concerns.

Thanks! :)
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on May 24, 2012, 11:29:09 AM
morga87 is receiving support via e-mail.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: byzman on May 30, 2012, 07:38:22 PM
I need help...downloaded app recently and it works great on wifi...but when I use 3G it is sporadic...sometimes it works sometimes it doesn't...so I tried port forwarding and I believe I did the steps correctly because i tried the port testing and it said it was open...but now I cant use it on 3G...need help?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Jay on May 31, 2012, 11:06:43 AM
Please email screenshots of your router's port forwarding settings to support@skjm.com so we can verify whether the router is configured correctly.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: abronbibly on September 30, 2012, 09:47:24 PM
I was able to setup port forwarding for my iMac - I have that iCamSource setup using 12000-12100 and it's working. I tried to setup my macbook using 12200-12300 and it's coming up blocked on portchecker.net for some reason.

I can't seem to get the router to allow the port forwarding for 12200-12300 when the 12000-12100 is forwarding. How can I get both machines to work with port forwarding and show up on iCam?

12000-12100 is showing open and 12200-12300 is showing blocked and I get a iCam source error when I tried to connect to the macbook using port forwarding 12200-12300.

I just noticed that if I change my router settings to be the macbook's IP address instead of my iMac's IP address, then it shows me the macbook's iCamSource instead. So the source is working - but for some reason the router won't let me assign 2 IPs a range of ports to forward. I wasn't sure what the original post mentioned when it said to setup a full range 12000-12500 and then assign each individual IP.. Can anyone clarify a little more? Both sources are working, but I can't get them to work together at the same time using both sources.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: abronbibly on September 30, 2012, 10:30:35 PM
I was able to figure out the issue for the multiple computers - I had to reorder the forwarding ports by IP for some reason.

One other question.. I'm trying to add a 3rd PC (not a Mac or Macbook this time) and I downloaded the iCamSource for the PC (windows7), but where do I setup the port forwarding in that version of the software? I can't run the terminal code like in Mac to get it to show up - so how do I get the port forwarding option to show up so I can assign it the correct ports?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on October 01, 2012, 06:21:14 PM
I was able to figure out the issue for the multiple computers - I had to reorder the forwarding ports by IP for some reason.

One other question.. I'm trying to add a 3rd PC (not a Mac or Macbook this time) and I downloaded the iCamSource for the PC (windows7), but where do I setup the port forwarding in that version of the software? I can't run the terminal code like in Mac to get it to show up - so how do I get the port forwarding option to show up so I can assign it the correct ports?

Port forwarding is done in your router's settings. What is the Brand/Model of your router?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: DX10Pilot on October 14, 2012, 01:17:09 PM
I've tried seaching and everything suggested. I can view my Icam on Wifi but not the internet.

Port Checker says UDP Port 12000 is blocked.

Tried making a static IP   using PF setup static, still didn't work

Linksys WRT54G router.
I entered the suggested settings in the router setup  still no joy....

It says something about setting up 6 individual ports, starting at 12000 - 12005      I have no idea how to do that.

Help?????
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: DX10Pilot on October 15, 2012, 03:33:07 PM
Couldnt open the port on the Linksys router, however I found a way to bypass the router and it works now. Close enuf I guess.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on October 15, 2012, 05:12:23 PM
If you would like to continue troubleshooting please send a screenshot of your router's port forwarding configuration to support@skjm.com (http://support@skjm.com) so we can verify the settings.

Also, if you could go to http://whatismyipaddress.com/ (http://whatismyipaddress.com/) from the computer running the iCamSource and send your external IP address to us so we can attempt to look it up in the Broker Server logs and hopefully troubleshoot the problem.

Please reference this forum post and your user name in your email.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: mikey76 on October 17, 2012, 11:47:03 PM
I can't connect via 3g/edge but can via wifi
I have a westell 7550 modem/router ATT it doesn't have UpNp but I can manually port forward, there was not listing for this model on port forward dot.com either
The options it give me to start/end/lan port so do I put 12000 in start 12100 in end and ? in the LAN. I tried putting 12000 for start/end/LAN it added my custom service "icam" successfully but I can't connect still via 3g, what am I doing wrong when setting up the port forwarding range fields since I have 3 fields to fill out..
Please help me
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: rjgvt on October 18, 2012, 04:41:48 AM
mikey,

I have a similar modem/router at a remote location and found that it was easier to bridge the modem so that it is just a modem and not a router. Then I used a Netgear router for port forwarding.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on October 18, 2012, 12:35:19 PM
mikey76 is receiving support via email.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: mikey76 on October 18, 2012, 12:43:06 PM
Thanks You Support Team for acknowledging my issue
I sent an email with screen shots of my westell router/modem w/ATT last night..
and I await your email with details on how to resolve the issue.

Thank
Mike
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: mikey76 on October 19, 2012, 11:18:14 AM
Its been over 24hrs and I still haven't gotten any email tech support on how to set up a westell modem/router from ATT and the ports you listed 12000-12500 are closed on port checker dot com. If I can't use the app on 3g/edge then its basically useless for me, it serves no purpose to only be able to use it on your own wifi network when your actually at home, the point for me is to use it when I'm away.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on October 20, 2012, 12:28:42 AM
We apologize for the delay. Have you received an email from us?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: mikey76 on October 22, 2012, 12:00:47 PM
Does anyone who had similar connectivity issues with 3g/edge can help let me know. I can connect via wifi but once I go cellular I get a icamsource error.

My issue is trying to manually config a westell modem/router from ATT, its asking me to for 3 port forwarding fields versus 2.
start, end, LAN ports, how do I set this up. I've tried putting 12000-12100 in all three several different ways and still no luck. Also, is there any other setting on my modem/router combo device that I should check or uncheck for this app to work. Has to be somebody with a modem/router combo device from a major internet provider that tried to use this and had issues...

Lastly, when I went to check the ports 12000-12500 were all CLOSED on portchecker.com on my homes internet account/connection,but the auto-config/ports work at my JOB, says "upnp success --->port 12000-12000" and the app works on 3g/edge so it's hope for me yet..maybe. Please help
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: mikey76 on October 22, 2012, 04:19:24 PM
Ok GOOD NEWS!! I got one of the iSight cameras to work via 3g/edge on my westell/netgear modem/router.
This is what I did I'll list the steps below. BUT I NEED ADVICE ON CONFIG FOR OTHER COMPUTERS/Cams to work simultaneously!! Please read this whole post.

1. I cut and pasted the command line code provided on this forum and pasted it in Terminal on my iMac
2. Then reopen iCamsource and saw "port forwarding 12000-12100" available to check box it..
3. Then I when to my modem/router admin via the internet on my ETHERNET connected iMac
4. Next, I when to port triggerting/add new service "iCamsource"/start-end port range 12000-12100/click enable when done.
5. Next, I when to port forwarding/add new service "iCamsource/start-end-LAN i put 12000 for ALL 3 fields then UDP
6. Last, I had to enable it, it then prompts for device name from drop down or device IP, I put in BOTH then click "done"
7. Refresh iCam app on iphone using 3g/edge connection, make sure iCamsource is running with port forward checked.
This works for one cam out of 4 possible cam slots

My question is to anyone including tech support is..
On my two macbooks I pasted that port forwarding line of code into terminal and now all my iCamsources say "portforwarding 12000-12100" is that okay? I read somewhere on here where you said the ports should be different if your running the software on multiple computers at once..
So for my macbook pro should I set it up on my westell/netgear as 12001 port and my macbook 12002 for single port forwarding since I used 12000 for the iMac? or should I use 12200 and 12300 respectively..
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on October 22, 2012, 10:30:11 PM
If you are running iCamSource(s) on more than one computer on the same network then you will need to use (and forward) a separate port range for each computer. (We recommend using 12000-12100, 12200-12300, 12400-12500, etc.)

There's more information about using port forwarding with iCamSource here: http://skjm.com/forum/index.php?topic=402.0 (http://skjm.com/forum/index.php?topic=402.0)
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: mikey76 on October 23, 2012, 11:06:44 AM
I got all computers/isights running on 12000-12004 I only have 4 computers but at least they all work now on 3g/edge when I'm not on wifi. Thanks for you advice and input.
Title: Still not working
Post by: Mzwei on December 01, 2012, 04:39:50 AM
I am using two Macs with Mountain Lion and set up the port forwarding for both Macs. I restarted the iCam Source software and there is in both settings windows the port forwarding option visible. One with 12000-12100, the second with 12200-12300. The port check website states, that all UPD  ports are open.


Why can I access my cams via the website but not from the iPhone App?

Thanks in advance!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on December 01, 2012, 01:37:14 PM
What is the brand & model of your network router?
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: linkdeezie on December 10, 2012, 02:45:37 PM
If this issue has been going on apparently for YEARS,why is there no apparent fix for it available via an updated version? I, TOO, am experiencing difficulty setting this thing up. The only reason I purchased iCam is because of its notification feature. I also have another "CAM" app that works flawlessly and even allows you to talk over your connection through the webcam (if it has a built-in speaker). Anyhow, I've tried all these remedies, port forwarding and whatnot, and I still cannot get this thing to properly function. It works while on my wifi at home, but not on 3G/4GLTE. It even sends me notifications of movement, but then when I try to open the app on my phone, it gives me error messages. WTH?!?!?!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on December 10, 2012, 10:21:30 PM
If this issue has been going on apparently for YEARS,why is there no apparent fix for it available via an updated version? I, TOO, am experiencing difficulty setting this thing up. The only reason I purchased iCam is because of its notification feature. I also have another "CAM" app that works flawlessly and even allows you to talk over your connection through the webcam (if it has a built-in speaker). Anyhow, I've tried all these remedies, port forwarding and whatnot, and I still cannot get this thing to properly function. It works while on my wifi at home, but not on 3G/4GLTE. It even sends me notifications of movement, but then when I try to open the app on my phone, it gives me error messages. WTH?!?!?!

iCam does "just work" for the majority of users, but there are setups that do require some additional configuration.

If you already have port forwarding configured on your router, I would like to try and confirm that your port forwarding is functioning as we expect it to. If you visit this link in your computer's web browser: http://portchecker.net/udp.php?p=12001 (http://portchecker.net/udp.php?p=12001)

... it will open a webpage that contains a Java Applet in it (similar to iCamWeb) that will be able to listen on port 12001 for a UDP packet to be sent from a server on the Internet to your computer.

If your port forwarding is functioning correctly then you should see a message saying that the port is "open." If it is not functioning correctly, it should say that it is blocked.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: bhenning12 on December 11, 2012, 07:54:28 PM
Hello,
I recently began using your ICam program and it works great on WiFi but unfortunetly like many others I am unable to connect over 4G/Edge. I attempted to set my port forwarding and still nothing. I tried the Port checker and it just says "Checking UDP Port : 12000 (please wait 5 seconds for the test to complete)" and thats it, no message ever comes up saying if it is open or not.
I have a Qwest Modem, Actiontec PK5000.

Any help you could provide would be much appreciated.

Thank you in advance for your assistance

Robert
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on December 12, 2012, 07:26:31 AM
Please send a screenshot of your router's port forwarding configuration to support@skjm.com (http://support@skjm.com), so we can verify the settings.

Also, if you could go to http://whatismyipaddress.com/ (http://whatismyipaddress.com/) from the computer running the iCamSource and send your external IP address to us so we can attempt to look it up in the Broker Server logs and hopefully troubleshoot the problem. Please reference this forum post and your user name in your email.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: RB_IS on January 04, 2013, 08:38:30 AM
Hi,

i am using iCam but have an issure with the unlocking of the used Ports. It seems like iCam is using more Ports than Port 12000-12100.
When I unlock these Ports in my Stateful Packet Inspection Firewall the Program does not work.
The Log files of my router tell me that there are other Ports used (i.e. Port 12623) and when unlocking Ports 12000-13000 the connection can be established.
So is there a specific Range of Ports that are used, too?
I don't want to open that many Ports just for one simple App...

Thanks in advance!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on January 07, 2013, 11:16:08 PM
The iCam Broker Server listens on UDP port 12613 so iCam and the iCamSource will need to communicate out to that port, in addition to the 12000 - 12100 range.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: janiemae on February 27, 2013, 03:12:13 PM
I have done all this things that you have stated , but we still cannot use our cameras.   Do you have the old original download for the icam.   The cameras, the internet and all worked then.  But I cant get them to work now.  I want and need this thing to work.

Thanks

Title: Re: Troubleshooting 103 - Port Forwarding
Post by: janiemae on March 08, 2013, 02:37:09 PM
Ya know, I have tried and done everything you have suggested and it still does not work.  Forwarded this and forwarded that.  Add ports etc.  This is crazy that it is this hard to get to work when it worked on the original program.  I updated and guess what.   It does not work.   Im done!!!!!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on March 08, 2013, 09:28:11 PM
I apologize for your frustrations. If you would like to continue troubleshooting and you already have port forwarding configured on your router, I would like to try and confirm that your port forwarding is functioning as we expect it to. If you visit this link in your computer's web browser: http://portchecker.net/udp.php?p=12001

... it will open a webpage that contains a Java Applet in it (similar to iCamWeb) that will be able to listen on port 12001 for a UDP packet to be sent from a server on the Internet to your computer.

If your port forwarding is functioning correctly then you should see a message saying that the port is "open." If it is not functioning correctly, it should say that it is blocked.

Also, please send a screenshot of your router's port forwarding configuration, so we can verify the settings, to support@skjm.com. Please reference this post and your username in the email.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Camilo on October 11, 2013, 06:24:16 AM
Been using this app and program for quite a while with no problems, until recently that is. Did the auto-configure thing, it worked for a few months but not quite as stable as before getting a lot of source connection errors. Now it just seems like I can never get it to work, occasionally it does pick it up if I am lucky enough. Like once out of 100 tries.

I followed the port forwarding guide, did the registry thing and checked the port range, forwarded the ports, set up a static IP (which I really don't get since i don't have to put the IP anywhere in the phone), & updated the iCam source.

I first ran the PFPortChecker, I was getting my IP address, ping result was not able to ping my router  but the port check result would be open open. (Ran the portchecker.net/udp.php?p=12000 and it would not work)

Then i ran the portchecker.net/udp.php?p=12000 again a few hours later and it said open but the PFPortChecker ping would b bad and same for the port check result would not open. (iCam would not work on 4G either.)

Now im getting a error binding to udp port 12000 on the portchecker.net/udp.php?p=12000.

At this point quickly losing patience and hope, ive read many posts and tried many different things. I dont understand how it went from fully working to absolutely not working ever, with out any configuration changes. do i need to buy proxy to make this work now? if so please let me know instead of misleading people.

EDIT** Upon playing with some of the settings even more, I put my IP address back to dynamic with the PF program. Now I am getting an open port 12000 on the portchecker.net/udp.php?p=12000 and on the PFPortChecker i am now getting and open port as well, I am still having issues with the ping results saying "we are not able to ping your router"

Some extra details my routers upnp is enabled and on the iCamSource next to auto-config router I have the UPnP may not be Enabled message.

Iphone 5s, 4G LTE, Router WRT160N v2, any suggestions? I really rely on this program for many purposes, i really need a fix.

Thank you very much in advanced. If additional information is needed, i will be glad to elaborate.

Title: Re: Troubleshooting 103 - Port Forwarding
Post by: SKJM Support on October 11, 2013, 10:58:49 PM
If you could go to http://whatismyipaddress.com/ (http://whatismyipaddress.com/) from the computer running the iCamSource and send your external IP address to support@skjm.com so we can attempt to look it up in the Broker Server logs and hopefully troubleshoot the problem. Also, please reference this forum post and your user name in your email.
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Vanduin on January 21, 2017, 08:15:27 PM
Hi!

In earlier versions of iCamsource it was possible to add two fields to define the port forwarding range via the terminal with this command:

defaults write com.skjm.icamsource PortRangeSet -bool true

If I try that with 2.8.5 on Sierra there are no fields added to define the port range.  :(

How can I enable the two fields to define the port range?

Thanks!
Title: Re: Troubleshooting 103 - Port Forwarding
Post by: Stefan on January 22, 2017, 01:23:57 PM
Are you running the iCamSource or the iCamSource Pro? (That command is for the non-Pro iCamSource.)

If you are running the iCamSource, have you tried restarting your Mac after running the command in the terminal window? Sometimes manual changes to the settings do not take effect until after the computer is restarted.